Troubleshooting
Problem
Multiple content stores created in different schemas of the same Oracle database are becoming corrupt. Either an error message is displayed or the install will not start.
Symptom
The following message is displayed after attempting to start, or authenticate into the product.
ORA-00001: unique constraint (schema.PK_name) violated.
Cause
An Oracle issue might be causing the content store corruption.
Environment
Oracle Content Store.
Resolving The Problem
This steps needs to be done by a Database Administrator (DBA) in most cases:
1. Stop all Cognos services on the computer where the Content Manager is installed.
1. Stop all Cognos services on the computer where the Content Manager is installed.
2. Using sqlplus (or any similar tool) connect to the content store database using username and password as specified in Cognos Configuration database resource properties and execute the SQL script <cognos install location>/configuration/schemas/content/oracle/AddConsistencyCheckFlag_oracle.sql
3. Start the Cognos services on the computer where Content Manager is installed. Wait until the following messages are logged in <cognos install location>/logs/cogserver.log
CM-SYS-2210 CM internal consistency check starts
and
and
CM-SYS-2211 CM internal consistency check completes
4. If there are no other messages between CM-SYS-2210 and CM-SYS-2211 indicating there are consistency problems, then the content store does not require fixing. If any inconsistencies are reported between the messages follow steps 6-9 to fix them.
5. Stop the Cognos services on the computer where Content Manager is installed.
6. Using Oracle tools take a backup of the data in the content store schema.
7. Using sqlplus (or any similar tool) connect to the content store db using username and password as specified in Cognos Configuration Database resource properties and execute the SQL script <cognos install location>/configuration/schemas/content/oracle/AddConsistencyFixFlag_oracle.sql
8. Start the product on the machine where Content Manager is installed. Wait until the following messages are logged in <cognos instlal location>/logs/cogserver.log:
CM-SYS-2210 CM internal consistency check starts.
and
CM-SYS-2211 CM internal consistency check completes.
Check for errors reported. Content Manager should start and be able to perform
without inconsistency related problems.
There is another way to check content store consistency that does not require restarting the product. It is described in IBM Cognos Administration and Security Guide - Part 7: Server Administration - Internal Content Store Maintenance. Note that if there are inconsistencies reported a restart is needed to fix them.
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Document Information
Modified date:
28 November 2022
UID
swg21340998