IBM Support

Launching DOORS results in "System Clock has been set back" error

Troubleshooting


Problem

Attempts to launch IBM Rational DOORS results in the licensing error "System Clock has been set back".

Cause

The "System clock setback detected" error could be encountered due to files present on the OS which are dated newer than the current date. This can be caused by modifying the date on the OS, which leaves a time 'footprint' of changed operating system file dates, or from shared files from other users. The FLEXnet software, being sensitive to such changes for security reasons, senses these forward-dated files and regards it as a security breach, thus generating the "System clock setback detected" error.

Resolving The Problem

Option 1: Perform the following steps on the license server to resolve the issue:

  1. Select Start > Search

  2. Select All files and folders

  3. Click on the When was it modified?

  4. Select the Specify dates option

  5. Select Modified Date from the drop down

  6. For the from field put in tomorrow's date

  7. For the to field put in a date 10 years from present

  8. Click the Search button


Option 2: Alternatively, you can also uninstall the license server and install it again.

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Licensing","Platform":[{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.3;9.4;9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21324817