Question & Answer
Question
How do you troubleshoot start up issues with IBM Rational DOORS?
Cause
The most common of error messages associated with a DOORS client start up failure are discussed below:
Table of Contents:
Color file C:\Program Files\doors\lib\rgb is missing
data directory LOCALDATA not set
data directory C:\Program Files\temp does not exist.
Cannot connect to server 36677@machine_name
Database is locked by a different DOORS server 36677@machine_name
License Error: DOORS cannot find the required license
License-key and data for the feature do not match.
This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986 |
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Below is an example:
[HKEY_CURRENT_USER\Software\Telelogic\DOORS\9.2\Config]
LOCALDATA = C:\Documents and Settings\Administrator\Application Data\Telelogic\DOORS\Temp
[HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS\9.2\Config]
ComputerName = machine1
Data = 36677@Server1
Home = c:\program files\IBM\rational\DOORS\9.2
Version = 9.2.0.0
For database server installations will contain additional settings.
On UNIX or Linux these values are set as environment variables.
On Windows there is a DOORS_Server Registry Section
[HKEY LOCAL Machine\Software\Wow6432Node\Telelogic\DOORS\9.5\config]
Home = C:\Program Files (x86)\IBM\Rational\DOORS\9.5
ServerData = C:\Program Files (x86)\IBM\Rational\DOORS\9.5\data\
PortNumber = 36677
Note: Prior to version 9.2, a utility named DOORS ERS Configuration Tool was provided to administer DOORS configuration settings. This tool is no longer provided as part of the installation.
Answer
</a></p></th></tr></table>] HOME is not set
Problem 1: HOME is not set
This can be caused by one of two problems:
- No Home= setting in the Registry on Windows
- On UNIX, no HOME environment variable
Solution:
Ensure the correct value is set for DOORS Home
Home should be set to the path of the directory where DOORS is installed. Modify the path entry if it is incorrect.
- On Windows the registry
HKEY LOCAL Machine > Software > Wow6432Node >Telelogic > DOORS > 9.5 > config
image
- UNIX environment variable is correct.
Color file 'C:\Program Files\doors\lib\rgb' is missing
Problem 2: Color file \C:\Program Files\doors\lib\rgb is missing
This is also caused by an error in the Home= variable
Solution: Ensure that the information contained in the Registry for Home or the UNIX environment variable is correct.
Home should be set to the path of the directory where DOORS is installed. Edit the path if it is incorrect.
data directory 'LOCALDATA' not set.
Problem 3: data directory 'LOCALDATA' not set
This is caused if there is no LocalData= setting
Solution: Edit this value to ensure it is correct. LocalData is an area that DOORS uses for the processing of temporary files. This can be in any writeable area of your disk such as
c:\temp or c:\program files\doors\temp
data directory 'C:\Program Files\temp' does not exist
Problem 4: data directory 'C:\Program Files\temp' does not exist.
This is caused if the LocalData= line does not point to a valid directory.
Solution: Edit this value to ensure it points to a directory which exists.
Cannot connect to server 36677@machine_name
Problem 5: Cannot connect to server 36677@machine_name
This can be caused by the following:
- The "Data =" variable does not point to a valid database server
- The database server is not running on the machine specified
- The machine in question is not reachable on the network
- The DOORS port number is incorrect, or (more common on UNIX/Linux)
your environment has an incorrect value for PORTNUMBER variable
Solution:
The DOORS client is looking for a database server at port 36677 on the machine mentioned.
If the DOORS database server is on a different machine, the Data variable should be set to the correct port number and the server machine name e.g. "36677@servername".
If the machine name mentioned is the location where the database server should be running,
verify the process is running using the netstat command, or use windows computer management to verify that the DOORS DB Server (DDBS) is listed and the status is started. If it does not appear, the database server will need to be installed.
Using a network verify that the server machine is reachable by using the ping command.
Database is locked by a different DOORS server 36677@machine_name
Problem 6: Database is locked by a different DOORS server 36677@machine_name
OR
-E- DOORS_DB_SERVER: Error getting exclusive lock on data: Database locked by server
This can be caused by the following:
- Another database server is running using this data
- The data remains locked by another database server but this server is no longer running
- The "Data=" variable does not point to the correct server.
Solution:
If the port number and machine name mentioned correspond to the database server which you wish to use, the content of the Data variable is most likely incorrect. Modify the value for the correct server
If the port number and machine name mentioned do not correspond to the database server which you wish to use, check the machine computer management services to confirm the DDBS mentioned appears. If it appears, stop it.
If the DDBS mentioned is not running, open the data directory and look for a file called servdata.dtc.
If it is present, remove it or rename it to servdata.dtc.old and restart the DOORS database server.
On UNIX/Linux, verify that PORTNUMBER is set correctly
- su to the DOORS user and run the env command
- Make sure that the environment is correct
- If any problems are found, fix them
- su to the DOORS user again, verify
- Restart DOORS
License Error: DOORS cannot find the required license
Problem 7: License Error: DOORS cannot find the required license.
This means that you have selected the wrong type of license setup.
DOORS may appear to hang when it starts up.
Solution:
Re-run the license setup to change to the correct license type.
License-key and data for the feature do not match
Problem 8: License-key and data for the feature do not match.
If the client starts on other machines without problems, this may be due to and incorrect data settings on the system clock being set incorrectly.
Solution:
Check the system clock on the machine and make sure that the date is set correctly.
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Document Information
Modified date:
01 May 2020
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