Troubleshooting
Problem
Attempts to search for Change Request (CR) text yields unexpected results in IBM Rational Change release 5.0 and earlier releases.
Symptom
When you search for text that you believe is in a CR but the results do not include the CR you expected.
Cause
There can be a number of reasons a search does not find the CR you are expecting.
- The index is not up to date
- The text you are searching for is not part of the index
- The index is corrupt
The search tool is only as good as the most recent index which has been run on the database.
Only those attributes which are marked as Reportable in your CR process are indexed.
By default only the CRs and tasks which are modifiable in the current database are indexed for the current session, though you can change this behavior: How to expand free text search index in Change so that all CRs and tasks are included
Environment
Only relevant for Rational Change release 5.0 and earlier.
If you have problems with later releases, you need to contact Rational Client Support.
Diagnosing The Problem
Steps to help troubleshoot the issue:
- The index is not up to date
Check the Admin GUI and the Change log files to see if Indexing is turned on when the most recent index update was run.
- The text you are searching for is not part of the index
Only those attributes which are marked asReportable
in your CR process are indexed.
If you are using Distributed Configuration Management (DCM) then only the CRs and tasks which are modifiable in the current database are indexed for the current session, though you can change this behaviour: How to expand free text search index in Change so that all CRs and tasks are included
Note: The free text search indexer indexes a subset of all the attributes that are marked as beingReportable
in the currently installed process. The subset is based upon the WebType of the attribute. Of the default WebTypes, the following list tells you whether or not indexing will occur:
CCM_LISTBOX = Yes
CCM_VALUELISTBOX = Yes
CCM_TEXT = Yes
CCM_STRING = Yes
CCM_READONLY = Yes
CCM_HIDDEN = Yes
CCM_DATE = No
CCM_TOGGLE = No
CCM_RELATION = No
CCM_NUMBER = No
CCM_USER = No
CCM_E_SIGNATURE = No
- The index is corrupt
Look in the Change log files to see if there are any errors relating to the index build.
Resolving The Problem
Apply one of the following solutions which match your issue:
- The index is not up to date
If Indexing is on and up to date try your search again. If you still cannot find the CR consider the next solution.
- The text you are searching for is not part of the index
If the attribute is notReportable
then you can modify the lifecycle to make itReportable
- The index is corrupt
If you continue to encounter issues after investigating the above, the behaviour could also point to an indexing issue. Specifically, there may be a corruption in the indices causing the database to return inaccurate results. The most complete resolution would be to rebuild the indices completely in an attempt to clear out any possible corruptions. You need to be aware that this could take a substantial amount of time if you have a large quantity of data to be indexed.
Rebuilding the search index:
- Login to Change
- Click Disable indexing from the Admin > General tab
- Stop Change
- Delete the wsconfig/system/index directory if it exists.
- Delete the wsconfig/system/search.tmr file if it exists.
- Delete the wsconfig/system/enabled.tmr file if it exists.
- Delete any .redo or .idx files.
- Restart Change
- Login to Change in the Admin role
- Navigate to the Admin > General tab
- Click the Indexing Enabled radio button to re-establish indexing
- Click Create Index
- Click OK to the pop-up message.
Once the indexing has completed, run a search again to determine if this has resolved the issue.
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Document Information
Modified date:
13 November 2019
UID
swg21324477