Question & Answer
Question
What information should be collected when I experience configuration issues with InfoSphere® Federation Server? Collecting this information before calling IBM® support will help you understand the problem and save time analyzing the data.
Cause
The following information is required by the InfoSphere® Federation Server Service team to troubleshoot a wrapper configuration issue.
Answer
Collecting data source configuration specific information:
1. Exact name of product installed by issue this command and operating system command prompt:
db2licm -l
2. Current version of DB2 engine level. Enter the following from an operating system command prompt:
db2level
3. The operating system type, and release, where Federation Server is installed. On UNIX/Linux, enter the following from an operating system command prompt:
uname -a
- For Linux, provide the vendor/flavor/release too
- On SuSE Linux, enter:
cat /etc/SuSE-release
- On RedHat Linux, enter:
cat /etc/redhat-release
On Windows, right click on "My Computer", then select the Properties option.
4. What is the data source used? Provide data source client and server exact release and version.
Examples commands:
- DB2 for LUW
Enter the following from an operating system command prompt:
db2level
Informix
Enter following from an operating system command prompt:
cd $INFORMIXDIR/bin
./ifx_getversion clientsdk
./ifx_getversion libasf.a
./ifx_getversion libasf.so
Oracle
Enter the following from an operating system command prompt:
cd $ORACLE_HOME/bin
./sqlplus
Microsoft SQL Server
Issue the following SQL statement (from the Microsoft Query Analyzer):
select @@version
IBM Branded DataDirect ODBC driver
Go to directory <IBM_branded_odbc_install_dir>/bin and execute below command:
ddtestlib <libname>
For example:
i) Get ODBC driver manager version:
ddtestlib <IBM_branded_odbc_install_dir>/lib/odbc.so
ii) Get Microsoft SQL Server ODBC driver version:
ddtestlib <IBM_branded_odbc_install_dir>/lib/VMmsss23.so
Sybase
sybase client version:
Go to directory $SYBASE/$SYBASE_OCS/bin and execute below command:
isql -v
Sybase server version:
Issue the following SQL statement after connecting database using isql command:
select @@version
go
Teradata
Start DWB
issue get version command
5. Have there been any recent changes to your environment (hardware, operating system, software version)?
6. Has this problem occurred before? If yes, do you have a previous PMR number?
7. How often does this problem occur?
8. Is this a production, development, or test environment?
9. What is the business impact of this problem?
Examples:
- a. Cannot roll out a new application
b. Cannot monitor in-store security systems
c. Losing money due to applications not talking to each other
10. Can the problem be reproduced? If so, provide exact details of problem including steps performed when problem encountered, exact error number and text; jobs, scripts, applications executing when problem occurred.
11. Have you successfully tested the connection to the data source server using the data source client?
IMPORTANT: InfoSphere Federation Server wrappers require a working connection from data source client (installed on Federated Server) to data source server. This has to work first before attempting wrapper configuration.
12. Wrapper configuration problem? Provide following for review:
- a. output of "env" command
b. content of "db2dj.ini" file
c. output of "db2set -all" command
13. Server or Nickname configuration problem? Have you successfully tested the connection to the data source server using PASSTHRU mode? If not, please try following and report results:
- a. db2 "connect to <FedDatabaseName>"
b. db2 "set passthru <ServerName>"
c. db2 "select count(*) from <tableName at remote data source>"
#DB2 zOS: sysibm.systables
#DB2 iSeries: qsys2.systables
#INFORMIX: informix.systables
#MSSQL: dbo.sysobjects
#ORACLE: sys.all_tables
#SYBASE: dbo.sysobjects
#ODBC: schema_name.table_name
d. db2 "set passthru reset"
14. Please run following commands to collect db2support, db2look and db2trace data:
- a. db2support <output_path> -d <db name> -cl 0
b. db2look -d databaseName -e -o output_filename -fedonly
c. db2trc on -f trace.trc # turn on tracing and trace all components
<Run command that recreate the error>
db2trc off # turn off tracing
db2trc flw trace.trc trace.flw # format the trace flow diagram into file trace.flw
db2trc fmt trace.trc trace.fmt # format the trace data into file trace.fmt
db2trc fmt -c trace.trc trace.fmc # format the trace data into file trace.fmc if DRDA wrapper
15. Provide <db2_install_path>/sqllib/cfg/db2dj.ini file
For ODBC and Microsoft SQL Server data sources, please provide your odbc.ini file and ODBC trace.
To enable ODBC trace, please refer to the following links:
a. Unix:
http://media.datadirect.com/download/docs/odbc/allodbc/index.html#page/troubleshooting/rfi1361811085889.html
b. Windows:
http://support.microsoft.com/kb/274551
16. Zip, or compress, all files and rename with PMR number as prefix before submitting ; example 12345.678.999.files.zip.
Submitting information to IBM Support
Once you have collected your information, you can begin Problem Determination through the product Support web page, or simply submit the diagnostic information to IBM support. Use the URL below for submitting information to IBM Support.
http://www.ecurep.ibm.com/app/upload
For a listing of all technotes, downloads, and educational materials specific to the InfoSphere® Federation Server component, search the product support site at the following link : http://www-01.ibm.com/software/data/infosphere/support/federation-server/
Product Synonym
InfoSphere Federation Server;WebSphere Information Integrator;WebSphere Federation Server;Federation Server;Information Integrator
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Document Information
Modified date:
16 June 2018
UID
swg21321031