Troubleshooting
Problem
If you use a parenthesis character anywhere in the IBM WebSphere Application Server Version 7.0 installation directory path, then the profile creation process might fail at the end of installation processing. This situation results in a partial success installation message.
Symptom
Also, command-line tools such as ivt.bat, versionInfo.bat, and startServer.bat might fail with an exception, such as in the following example:
C:\Program Files (x86)\IBM\WebSphere\AppServer\bin>versionInfo |
Cause
The parenthesis character is not interpreted properly by WebSphere Application Server Version 7.0 command processing.
Resolving The Problem
To resolve the problem, download and apply Interim Fix PK71847 to your existing installation. This Interim Fix enables WebSphere Application Server command-line tools to run properly when the installation directory path contains a parenthesis character.
In addition, the following alternative workarounds exist for this issue:
- Uninstall the product and then install it to a different directory path that does not contain parenthesis characters.
- Manually create a profile with the Profile Management tool after you install the product binaries. Then, the WebSphere Application Server commands, such as the versionInfo.bat command, will work correctly.
- Create a profileRegistry.xml file with the following line in the app_server_root/properties directory:
<?xml version="1.0" encoding="UTF-8"?><profiles/> |
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21318409