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Duplicate IP address detected errors reported with IBM WebSphere Load Balancer high availability

Troubleshooting


Problem

An error indicating duplicate IP address detected is reported occurs when the WebSphere® Load Balancer's  high availability (HA) feature is used.

Cause

The high availability feature of the IBM WebSphere Load Balancer joins two machines such that one machine is available to takeover and manager the cluster addresses. As such, when a takeover occurs messages indicating "duplicate IP address detected" are reported and the messages are normal. The duplicate address detection occurs when the ethernet adapter MAC address associated with the IP address changes. When the cluster address moves to the partner Load Balancer, adapter MAC address changes and the 'duplicate IP address detected' message is reported. The duplicate adapter conditions are present when the Load Balancers are started or when the backup takes over forwarding. 

Resolving The Problem

The "duplicate IP address detected" message is normal behavior. To understand the Load Balancer's high availability feature and the cause of takeovers, see this technote:
Troubleshooting WebSphere Edge Load Balancer High Availability failover

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Document Information

Modified date:
12 January 2022

UID

swg21207969