Troubleshooting
Problem
"An unexpected error has occurred" error message shows up when a new user attempts to access Planning Analytics Workspace.
Symptom
1)New users receive "An unexpected error has occurred" error message while accessing the Planning Analytics Workspace url
2)Existing users can access Planning Analytics url without any issues.
3)Attempts to upload users through a csv file results in below mentioned error
{"message" : "Failed to synchronize tenant"} {"reason" : "An error occured while saving data to database. Please check the data or the database connection."}
Cause
The issue is caused due to permission issues on the bss container volume.
Diagnosing The Problem
1)Everything works on the environment without any issues except addition of new users.
2)All the containers including bss loads up without any issues when Planning Analytics Workspace is restarted.
Resolving The Problem
1)Execute the below command on the server hosting Planning Analytics Workspace
docker exec -u root -it bss chown -R pauser:pagroup /opt/harmony/bss/wlp/usr/servers/defaultServer/db
2)Restart the Planning Analytics Workspace services using .\paw.sh or .\paw.ps1 depending on the host operating system
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"Component":"Planning Analytics Workspace","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
21 February 2020
UID
ibm13160713