Troubleshooting
Problem
Intermittently, users receive errors when using Controller.
Symptom
The errors will vary, depending on what the user is doing at the time.
Example #1 - Trying to launch Controller client:
The request failed with HTTP status 404: Not Found
Example #2 - Trying to run a consolidation:
Access to the path 'C:\Cognos\ccr\ccr.config' is denied
Cause
The value of the Windows %APPDATA% variable has been modified to a network location.
- This is not supported by IBM.
More Information:
The Controller client reads from and writes to a configuration file called 'ccr.config'.
- This is located here: %APPDATA%\Cognos\CCR\ccr.config
- By default, this is: C:\Users\%USERNAME%\AppData\Roaming\Cognos\CCR\ccr.config
However, if the I.T. department have modified the value for %APPDATA% (for example redirected user's profiles to be stored on a remote network file share) then this means that ccr.config reads/writes are slower.
- In some environments, these are so slow that Controller aborts trying to read/write to that location, and falls back to a default local location (C:\Cognos\ccr\)
- However, only one person at a time can use that location, therefore errors will occur (when trying to read the configuration file) if a different user tries to read that file.
Environment
Some of the errors could potentially exist in any environment, but it is more likely that they will occur when using Citrix (or Terminal Services).
- This is because several users share the same server, therefore only one can write to the file C:\Cognos\ccr\ccr.config simultaneously.
Resolving The Problem
Reconfigure the environment so that users do not read/write their ccr.config files on remote (network) locations.
- Specifically, ask your I.T. department to modify their policies so that the %APPDATA% variable is located on a local hard drive (for example the C: or D: drive of the Citrix server).
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Document Information
Modified date:
15 June 2018
UID
swg22013996