Troubleshooting
Problem
User runs any standard report (for example 'Maintain > Account Structure > Reports '). User changes 'Select Format' to XLSX. User is prompted "Do you want to open or save this file?". User chooses 'Open'. An error appears.
Symptom
- Microsoft Excel has stopped working
APPCRASH
EXCEL.EXE
ntdll.dll
c0000135
Cause
Limitation of Controller (when the report server is configured to be untrusted) triggered by 'protection' settings of Excel.
Environment
Both of the following are true:
(1) The report server address (for example 'analytics.ibmcloud.com') is configured to be inside the client device's Internet Explorer "Internet" zone (therefore Excel will not trust the Excel spreadsheet)
(2) The client device's Microsoft Excel is configured to have 'Protected View' enabled for files originating from the Internet (and potentially unsafe locations):
Resolving The Problem
Modify Excel to not use 'Protected View' (for the methods that you open Excel spreadsheets).
- For example, unticking 'Enable Protected View for Outlook attachments' will cause Outlook attachments to not open in 'Protected View' mode (which is triggering this problem).
Steps:
Method #1 (Manual)
The following steps are based on Excel 2016. They may need to be modified slightly for different versions:
1. Logon to the client device (for example the end user's PC) using their Windows user account
2. Launch Excel
3. Click "File - Options"
3. Click "Trust Center" then click "Trust Center Settings":
5. Untick both of the following options:
- "Enable Protected View for files originating from the Internet"
- "Enable Protected View for files located in potentially unsafe locations":
6. Click OK.
Method #2 (Automatic)
Ask your I.T. administrator to create a Microsoft Active Directory policy (GPO) to perform the above changes.
- Specifically, make sure that these settings are 'disabled':
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Document Information
Modified date:
15 June 2018
UID
swg22013941