Troubleshooting
Problem
Attempts to cancel order in Included in Shipment status leads to the error YFS10137 in IBM Sterling Order Management
Symptom
The complete error is as follows:
<Error ErrorCode="YFS10137"
ErrorDescription="YFS: Order cannot be modified in current status"
ErrorRelatedMoreInfo="" ErrorUniqueExceptionId="9.113.36.5215185031005810000000000069">
<Attribute Name="ErrorCode" Value="YFS10137"/>
<Attribute Name="ErrorDescription" Value="YFS: Order cannot be modified in current status"/>
<Attribute Name="OrderHeaderKey" Value="2017121113044138135"/>
<Attribute Name="Override" Value="N"/>
<Attribute Name="OrderNo" Value="TestOrder"/>
<Attribute Name="EnterpriseCode" Value="DEFAULT"/>
<Attribute Name="DocumentType" Value="0001"/>
<Attribute Name="ModificationLevel" Value="ORDER"/>
<Attribute Name="ModificationType" Value="CANCEL"/>
<Attribute Name="ErrorUniqueExceptionId" Value="9.113.36.5215185031005810000000000069"/>
<Attribute Name="UserId" Value="admin"/>
<Attribute Name="ProgId" Value="ISCCSSYS001"/>
Cause
This is working as designed.
Diagnosing The Problem
- If the Node is a non WMS Node the application will not allow the cancellation of the line in IncludedInShipment status as Distributed Order Management does not have visibility to to the tasks carried out on the shipment and its inventory movements.
- If the Node is a WMS node then the order can be cancelled when in IncludedInShipment status.
Resolving The Problem
As a work around, you can can first cancel the shipment and then the order.
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Document Information
Modified date:
11 February 2020
UID
swg22013807