IBM Support

Design Manager client extension ifix fails to complete installation in IBM Rhapsody client

Troubleshooting


Problem

When logging in to the Rhapsody Design Manager server from the Rhapsody client, you are informed that the client and server version are out of sync and then prompted to install an ifix. However, after restarting the client, the installation has silently failed and you are presented with the same message again.

Cause

The fix is downloaded to a location in the C:\ProgramData\IBM\Rational\Rhapsody directory and the Rhapsody client requires administrator privileges to install the fix.

Resolving The Problem

You must have elevated privileges to install the fix successfully:

a) Run Rhapsody as administrator user (right click the Rhapsody shortcut > Select Run as Admin). This is a temporary fix and would only need to be done when a ifix patch install is required.

OR

b) Grant the current user full control access to the C:\ProgramData\IBM\Rational\Rhapsody directory. This is a permanent solution and doesn't require Rhapsody to be run as administrator.

You should use whichever method is most suitable for your internal IT policy.

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Product Synonym

Rational Rhapsody

Document Information

Modified date:
27 May 2022

UID

swg22013736