IBM Support

Can't connect to the LDAP server: CAM-AAA-014 CAM-AAA-0064 CAM-AAA-0056 CAM-AAA-0026

Troubleshooting


Problem

When trying to attach to an LDAP Directory Server, either by using the test functionality in Cognos Configuration or by starting IBM Cognos 11, an error message is logged and the connection fails.  This is true for LDAP and LDAPS (LDAP via SSL).

Symptom

CAM-AAA-0146 The namespace <namespacename> is not available.
CAM-AAA-0064 The function 'CAM_AAA_Configure2' failed.
The user cannot access the application at this time.
CAM-AAA-0056 Unable to authenticate.
CAM-AAA-0064 The function 'LDAPHandlePool::CreateHandle()' failed.
CAM-AAA-0026 The function call to 'ldap_simple_bind_s' failed with error code: '91'
Can't connect to the LDAP server

Cause

The product is unable to communicate with LDAP Server using the host:port defined for the Namespace in Cognos Configuration.

Resolving The Problem

Ensure that the computer being used for LDAP is able to be found via the network using common network utility tools.
Steps:
1) Use tools like ping and tracert  to verify the machine name/ip is able to be found.
2) Use the telnet application to ensure the host is reachable via this port.
3) Check for network firewalls between the Product and the LDAP server.
4) Check for Windows firewall blocking on the client (if applicable).
5) Use OpenSSL to test the connection to the LDAP server.
6) If necessary, contact your Network Administrator.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"11.0.9;11.0.8;11.0.7;11.0.6","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22013733