IBM Support

How do I reset Guardium enterprise search?

Question & Answer


Question

My Enterprise search window is showing no data or "Please Contact Your System Administrator". Some managed units (MU) are active when viewed in the Central Manager (CM), but not all. How can I reset enterprise search to try and resolve those problems?

Cause

Enterprise search relies on data indexing on the collectors and communication between the CM and MUs to coordinate the data. Many problems with enterprise search are related to the communication between the units. After communication or configuration problems are resolved, resetting of enterprise search may be required to start it working again.

Answer

1. Confirm that port 9983 and 8983 are open bidirectionally between the CM and all MUs.

2. Reset the configuration on the CM cli:

    grdapi reset_solr_configuration
3. Wait 10 minutes to ensure the internal processes on the CM are up and running. Check you can login successfully to the GUI before proceeding.

4. Set the search options from the CM. In most cases cm_only is recommended. From cli:
    grdapi set_enterprise_search_options distributed_search=cm_only
Note - In all_machines mode, ports in step 1 must be open between all appliances. Including from MU to MU.

5. Reset the MU connection to the CM. On each of the MUs run in the cli:
    restart network
6. Wait 10 minutes to ensure all the MUs are up, then check the search window in the CM.

If there are still problems and you need to contact Guardium support, collect support must_gather datamining_issues from the CM and at least one MU.

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Document Information

Modified date:
16 June 2018

UID

swg22013485