IBM Support

Case sensitivity and Groups

Question & Answer


Question

Unable to create new group with same name, but different case. Error : Group with same name xxxxx already exists

Cause

Group 'smith' in lower case already exists :


Attempting to create another group with same name 'SMITH' , but in different case , gives error :


Answer


This is working as designed .

Groups members in Guardium Groups are not case sensitive. So Guardium cannot support Upper and Lower case database names for
monitoring in groups. Guardium thinks, for example user 'SMITH', is the as 'smith' .

Please note , :
- Queries with group in Guardium are not case sensitive
- Quick search is case sensitive if you supply a double quotes around the search string.
- Also in regular expression double quotes make it case sensitive

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"10.0;10.0.1;10.1;10.1.2;10.1.3;10.1.4;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22012999