IBM Support

Slow login in Cognos Analytics

Troubleshooting


Problem

Login is slow when accessing Cognos via the gateway URI in all browsers.

Cause

Web content is set to expire immediately in the IIS settings.

Resolving The Problem

Steps:

1. Open IIS Manager and select the virtual directory for Cognos Analytics (eg: ibmcognos).

2. On the Features View pane, double click on ‘HTTP Response Headers’.

3. In the Actions pane (side bar on the right) click on the ‘Set Common Headers...’ option.

4. A ‘Set Common HTTP Headers’ dialog box will open. Check the ‘Enable HTTP keep-alive’ and the ‘Expire Web Content’ check box.

5. Under ‘Expire Web Content’, tick the ‘After’ option and type in 1 day and click on ‘OK’

6. Restart IIS.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22012969