IBM Support

Control Center will not install get error from CCInstall64.bin

Troubleshooting


Problem

Trying to install IBM Control Center using the command; CCInstall64.bin -i console

Symptom

-bash-4.2$ sh CCInstall64.bin -i console


Preparing to install


Extracting the JRE from the installer archive...


Unpacking the JRE...


Extracting the installation resources from the installer archive...


Configuring the installer for this system's environment...

Launching installer...


=======================================================


Installer User Interface Mode Not Supported


Unable to load and to prepare the installer in console or silent mode.


=======================================================

Cause

software bug in new version of Flexera InstallAnywhere

Environment

UNIX, LINUX, AIX

Resolving The Problem

How to work around the following error message when IBM Control Center installer is launched in “console” mode on Linux platform?

Fix 1:

From the prompt, unset the DISPLAY variable and re-launch the installer.
$ unset DISPLAY

$ sh CCInstall64.bin -i console


Fix 2: 


If the Fix 1 does not work, then try the following:

$ export IBM_JAVA_OPTIONS="-Djava.awt.headless=true"

$ sh CCInstall64.bin -i console

Fix 3: 


If the Fix 2 does not work, then try the following:

Remove one or both of the following packages and re-launch the installer.


This fix helped in a Red Hat Linux 7.4 environment.


xorg-x11-fonts-Type1-7.5-9.el7.noarch


stix-fonts-1.1.0-5.el7.noarch

[{"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"6.1.1;6.1.0.1;6.1","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

swg22012901