IBM Support

Unable to refresh or create Dynamic Reports

Troubleshooting


Problem

IBM Planning Analytics for Microsoft Excel is unable to refresh or create Dynamic Reports.

Symptom

Dynamic Reports containing DBRW formulas show #VALUE, rather than calculated values.

Cause

Dynamic Reports may not be able to refresh or be created if the connection between Planning Analytics for Microsoft Excel and PMHub has timed out.

Resolving The Problem

A recourse for this issue is to disconnect and reconnect to TM1 Server, and then rebuild the Dynamic Report by pressing ALT+F9.

The issue can be resolved by ensuring that PMHub and TM1 Server have the same timeout settings.

PMHub (located in servername:portnumber/pmhub/pm/admin > Configurations > PMHub Session
Setting):

  • MaxInactivityTimeout

TM1 Server (located in tm1s.cfg)
  • HTTPSessionTimeoutMinutes
  • IdleConnectionTimeOutSeconds

[{"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Planning Analytics v2.0 for Microsoft Excel","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2.0.2;2.0.1;2.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22012793