IBM Support

Unable to run a report in the background to send it via email: "RSV-DST-0009 The print process returned a status code of 27"

Troubleshooting


Problem

Every time users run a report in the background to be sent via email it gives an error. When checking under Admin past activities and going through the run history the following error can be seen for the run: RSV-DST-0009 The print process returned a status code of 27.

Cause

"Print Report" item is checked by default when the user clicks on the delivery for the report.

Resolving The Problem

For a user with Admin privileges, for any report the default option available when doing a Run in background is selected to 'Save report' by default instead of the 'Print Report' option. But in this scenario, the default delivery option is Print the report since the users have been denied the ability to save the report.

Steps to resolve the issue:

You can give the owner of the report write permissions if they don't have it, then your regular users can use the "With owner capabilities" to run the schedule as this will allow them to create saved output without giving them Write permissions on the report itself.

Alternatively you could create a report view of the report on which you give the users Write permissions. This way they will not be able to modify, delete, or overwrite the original report, but they will be able to created saved output for the report view and send links by email without any issue.

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Document Information

Modified date:
15 June 2018

UID

swg22012777