Troubleshooting
Problem
During a Data Protection for SQL backup, the following errors can be seen when using client side deduplication : ANS7899E (RC254) The client referenced a deduplicated extent that does not exist on the IBM Spectrum Protect server
Symptom
The following messages are also logged within the client error log :
ANS7900W Deduplication cache has been reset because it is not synchronized with the TSM server
ANS7899E The client referenced a deduplicated extent that does not exist on the TSM server
Cause
This will only be seen when using client side deduplication with a local cache for Data Protection (API) products and on this occasion was seen when running a backup from Data Protection for MS SQL with multiple sessions
Resolving The Problem
Do not use client side deduplication with a local cache when running IBM Data Protection products.
This is documented as a restriction within the performance tuning guide and using the API guide :
https://www.ibm.com/support/knowledgecenter/SSGSG7_7.1.6/perf/t_client_tuning_dedup.html
https://www.ibm.com/support/knowledgecenter/en/SSGSG7_7.1.8/api/c_dedup.html
Restriction
For applications that use the Tivoli Storage Manager API, do not use the client data deduplication cache because backup failures can occur if the cache becomes out of sync with the Tivoli Storage Manager server. This restriction applies to the Tivoli Storage Manager Data Protection applications. Do not configure the client data deduplication cache when you are using the data protection products.
If you need to use client side deduplication, disable the use of the local cache, so amend the option "ENABLEDEDUPCACHE" to "NO" within the client option file.
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Document Information
Modified date:
17 June 2018
UID
swg22012480