IBM Support

Windows Authentication prompt when downloading Excel Output

Troubleshooting


Problem

When downloading an Excel or CSV report output in IBM Cognos Analytics, one or more Windows Authentication prompts may appear.

Symptom

Windows Authentication prompt on appears to the user when Excel or CSV report output download.

Cause

Microsoft Office is verifying whether the server the file is being downloaded from has certain features such as Webdav or Sharepoint enabled.

Environment

  • Cognos Analytics 11
  • IIS with Windows Authentication
  • Internet Explorer
  • Microsoft Office 2010 or higher

Resolving The Problem

This is a feature by Microsoft.
Note: Links have been updated to use web.archive.org because Microsoft has removed these articles due to being written for Office 2003, which is no longer supported, however the information in the document still applies to how Excel works in later versions and is still considered valid.

An alternative is to select Save instead of Open when prompted to download an Excel or CSV file.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.9;11.0.8;11.0.7;11.0.6;11.0.5;11.0.4","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
27 October 2021

UID

swg22012478