IBM Support

Attempting to connect to a Micosoft OLE DB Provider for Oracle in IBM i2 iBase results in error and fails to connect

Troubleshooting


Problem

Using the iBase Importer, upon selecting the OLE-DB Data Source button to connect to Oracle, the Microsoft OLE-DB Provider for Oracle option results in an error message and fails to connect. Connecting to the Oracle database is successful through SQL+ and through a test DSN connection.

Symptom


Test connection failed because of an error in initializing provider.
Oracle client and networking components were not found. These
components are supplied by Oracle Corporation and are part of
the Oracle Version 7.3.3 or later client installation.

Provider is unable to function until these components are installed.




Cause

iBase itself is a 32-bit application and the Microsoft OLE-DB Provider for Oracle is a 32-bit version driver, so it's not seeing the 64 bit driver at all, hence the error message.

Environment

Oracle Client 11.2.0
iBase 8.9.11

[{"Product":{"code":"SSXW43","label":"i2 iBase"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.11;8.9.11.1;8.9.11.2","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22011979