IBM Support

Permission Denied while trying to access the Distribution group option

Troubleshooting


Problem

Attempts to open Distribution group in IBM Sterling Order Management leads to the Permission Denied error.

Symptom

Steps to replicate:

  1. Create a user group.

  2. Give permissions to Distributed Order Management.

  3. As a group user, try to access the Distribution Group section under Application Manager - Distributed Order Management - Cross Application - Order Promising - Sourcing and Scheduling - Provided Services/ Product being delivered

    This leads to 'Permission Denied' message.

Cause

Required user permission are missing.

Diagnosing The Problem

Application console does not show the option to give access on Distribution group, rather it shows for distribution rule only. There is Additional permission has to be given to distribution rule.

Resolving The Problem

Steps to resolve:

  1. Launch Application Manager with administrator user id.


  2. Navigate to Applications - Application Platform-Security - Groups -{Open Specific User Group} - Permissions tab- Global Inventory Visibility - Applications - Application Manager - Distribution Rules.


  3. Provide the permission to the group.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.2.1;9.3;9.4;9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg22011637