IBM Support

Script error when accessing Oracle Web ADI after installing Planning Analytics for Microsoft Excel

Troubleshooting


Problem

After installing Planning Analytics for Microsoft Excel, users may see a 'Member not found' script error message and references to specific .js files when accessing Oracle Web ADI.

Cause

This issue is the result of the following registry keys being added during the Planning Analytics for Microsoft Excel installation:
  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION\EXCEL.exe
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION\EXCEL.exe

Resolving The Problem

These registry keys can be deleted to resolve the issue. Before you delete the keys, these keys should be exported by right-clicking on the key and selecting the Export option.

To delete these keys:

  1. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION\ and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION\ .
  2. Right-click on the EXCEL.exe keys.
  3. Click Delete. This will remove the key and the values for the key.
EXCEL.exe key

Note: A system restart is not required for this change to work, however Microsoft Excel needs to be restarted.

[{"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Planning Analytics v2.0 for Microsoft Excel","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2.0.3;2.0.2;2.0.1;2.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
06 September 2019

UID

swg22011178