IBM Support

When updating a report in Report Authoring UI  the ID of the report is change

Troubleshooting


Problem

When updating a report in Report Authoring UI  the ID of the report is changed and therefore  schedules associated with it are dropped. Steps described in http://www-01.ibm.com/support/docview.wss?uid=swg21625148 do not resolve the problem

Cause

Content Manager overwrites the report object rather than updating its properties.

The steps in http://www-01.ibm.com/support/docview.wss?uid=swg21625148 are applicable to Cognos 10 but are not applicable to Cognos Analytics

Resolving The Problem

For Cognos 11.1.x and Cognos 11.2.x
  1. Log in to Cognos with a user that has System Administrator privileges.
  2. Navigate to Manage -> Configuration -> System -> Advanced Settings.
  3. Use ContentApps.updateTargetObjectWhenOverwrite as the key and true as the value.
https://www.ibm.com/support/pages/node/6195433
Upgrade to 11.07,

open http://server:port/bi/utils/ConfigSetter.html and set      
"Portal.updateTargetObjectWhenOverwrite" to true

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
07 October 2022

UID

swg22010981