IBM Support

Maximo Interim Fix installation error CRIMA1076E

Troubleshooting


Problem

Installing a Maximo Integration Framework (MIF) or Work Centers Interim Fix after some TPAE Interim Fixes causes a IBM Installation Manager error.

Symptom

Error on screen is

CRIMA1076E: Error executing the \maximo/tools/maximo/internal/unzipHotfixIfNeeded.bat
command: status=1.

Cause

It happens because both packages update the same Installation Manager application. IBM Installation Manager (IM) is reading the TPAE Interim Fix (IFIX) date.

The error is expected. For example: TPAE IFIX 003 has a release date (20170914) of Sep. 24, 2017. The value of the release date is greater than MIF IFIX001 (20170824) of Aug. 24, 2017. Although the fixes are cumulative, the tool used inside IM to determine whether an IFIX should be applied does not have the concept of components, so once you apply a TPAE IFIX, anything older than this IFIX will not be applied anymore (by automation).

Resolving The Problem

If the Interim Fix must be applied, follow the steps below to manually apply the IFIX:

Unzip the ifix into a directory. For example,<ifix_download_location>MIF_7608_IFIX.20170824-1250.im
Exploded IFIX zip file
From this location, copy the \MIF_7608_IFIX.20170824-1250.im\files\hotfixTool_7.6.0.0.zip file into the <maximo_install_dir>\maximo location.
Move HotFix Tool
Start an administrative command prompt. Change directory to <maximo_Install_Dir>/maximo/tools/maximo/internal
Run: <InstallDir>/maximo/tools/maximo/internal/unzipHotfixIfNeeded.bat -l<instDir>/maximo/tools/maximo/internal/unzipHotfixIfNeeded20170824-1250.log -v20170824 -f<unzipHotFixDir>/files/MIF_7608_IFIX.20170824-1250.zip -d<maximo_install_dir>/maximo

where:
-l is a minus lower case L which is a location for a log file to show results of running this command
-v is the version
-f is the file to unzip if it applies to this system
-d is the install directory of maximo

Example: Maximo installation directory is C:\IBM\SMP\maximo, download location is C:\downloads

unzipHotfixIfNeeded.bat -lC:\IBM\SMP\maximo\tools\maximo\internal\unzipHotfixIfNeeded20170824-1250.log -v20170824 -fC:\downloads\MIF_7606_IFIX.20170824-1250.im\files\\MIF_7608_IFIX_7.6.020170824-1250.zip -dC:\IBM\SMP\maximo

Command Line example

Check unzipHotfixIfNeeded.020170824-1250.log for any errors.

UnzipHotfixIfNeeded log shows Hotfix has already been applied

You may get an error showing that it is already installed, for example: "Hotfix 020170824 has already been applied."

If so, extract <ifix_download_location>MIF_7608_IFIX.20170824-1250.im.zip\files\MIF_7608_IFIX.20170824-1250.zip\files\MIF_7608_IFIX_7.6.020170824-1250.zip into <maximo_install_dir>\maximo location, overwriting existing files.

If you used Configuration Tool to setup your environment, note that, there is some code run to allow the configuration tool to show that an update was made to the system. You can start the configuration tool and run updateDB and build and deploy the ear files even though the display doesn't show it as needed.

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Document Information

Modified date:
08 April 2024

UID

swg22010436