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Unable to cancel an orderline when YFSOrderRepricingUE is enabled

Troubleshooting


Problem

Consider the following scenario - 1. YFSOrderRepricingUE has been implemented 2. An order has two lines, one of which is invoiced and the other line has been shipped. 3. Attempts to cancel the shipped line throws an error - You cannot change the price of an order after invoicing is complete This is not expected since no changes are being made to the invoiced line or the invoiced total

Cause

This could be due to the output returned by YFSOrderRepricingUE.

Diagnosing The Problem

The output returned by YFSOrderRepricingUE had both the orderlines even though the change in price was only for the shipped line. This caused the product to attempt to make a price change on the invoiced line as well, leading to the error

Resolving The Problem

Ensure that only the lines whose price is modified is being returned in the output of YFSOrderRepricingUE .

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Sterling Call Center","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.3;9.4;9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22010426