Troubleshooting
Problem
User launches 'main' Controller client. User clicks "Reports - Run". An error appears.
Symptom
CCR has stopped working
Event Log:
Log Name: Application
Source: Windows Error Reporting
Date: 8/23/2017 10:48:59 AM
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: PCNAME
Description:
Fault bucket , type 0
Event Name: CLR20r3
Response: Not available
Cab Id: 0
Problem signature:
P1: ccr.exe
P2: 10.2.5140.20
P3: 579f1ada
P4: ControllerFrmCommon
P5: 10.2.5140.20
P6: 579f1b12
P7: 878
P8: 172
P9: System.InvalidCastException
P10:
Attached files:
These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_ccr.exe_41ad3c3ffb82071ba217264b678961d137d8dc_00000000_07a070e5
Analysis symbol:
Rechecking for solution: 0
Report Id: 2025bd9b-87cf-11e7-ad60-ec8eb5a7b38a
Report Status: 528484
Hashed bucket:
Cause
There are several known causes for the generic "CCR has stopped working" error when clicking 'Reports - Run'.
- TIP: See separate IBM Technote #2011694 for more examples.
This Technote specifically relates to the scenario where the cause is that the client device has incompatible settings relating to Excel.
Example:
In one real-life example, the incompatible setting was having both of the following installed:
- Excel 2010
- Skype for Business 2016.
Diagnosing The Problem
To find out what the incompatible setting is, try disabling Excel from eagerly loading in Controller.
Steps:
1. Ask the user to launch Controller, and logon to any database
2. Click 'Maintain - Installation - Local Preferences'
3. Create a new key: excel_eagerload
- value: false
4. Save changes
5. Exit Controller, and re-logon
6. Click "Reports - Run"
- The old (generic) error will not instantly appear, because Excel has not been invoked in the background
7. Choose a report (and some parameters) and choose 'Send to application'
- A different (non-generic) error will appear, which gives enough information to allow diagnosis of the root cause, for example:
Example:
In one real-life customer example, after doing the above they got this error:
This error matches the same error that you would get if you had 'Skype for Business 2016' installed as well as Office 2010, so therefore it was possible to work out what the root cause was.
- TIP: For more details, see separate IBM Technote #1992629.
Resolving The Problem
Reconfigure the client device to not have the incompatible settings.
Example:
In one real-life customer example, the solution was to uninstall 'Skype for Business 2016' from the client device.
- TIP: For more details, see separate IBM Technote #1992629.
Related Information
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg22009880