Troubleshooting
Problem
Attempt to start IBM Cognos Configuration fails on Testing Content Manager database connection: Content Manager failed to start because it could not load driver “com.ibm.db2.jcc.DB2Driver”.
Symptom
[Content Manager database connection] |
Cause
Caused due to not having the DB2 Client Driver files in the relevant location.
Resolving The Problem
Steps:
1. Obtain a copy of the files "db2jcc.jar" and "db2jcc_license_cu.jar" (By default, you should be able to find these files on a Windows DB2 server in the following folder: ..Program Files\IBM\DB2\SQLIB\java\).
2. Paste these jar files in the 'drivers' folder of your Cognos install.
3. Restart Cognos Services.
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg22009618