IBM Support

Attempt to start IBM Cognos Configuration fails : Content Manager failed to start because it could not load driver “com.ibm.db2.jcc.DB2Driver”.

Troubleshooting


Problem

Attempt to start IBM Cognos Configuration fails on Testing Content Manager database connection: Content Manager failed to start because it could not load driver “com.ibm.db2.jcc.DB2Driver”.

Symptom

[Content Manager database connection]
[ ERROR ] The database connection failed.
[ ERROR ] Content Manager failed to start because it could not load
driver "com.ibm.db2.jcc.DB2Driver"

Cause

Caused due to not having the DB2 Client Driver files in the relevant location.

Resolving The Problem

Steps:
1. Obtain a copy of the files "db2jcc.jar" and "db2jcc_license_cu.jar" (By default, you should be able to find these files on a Windows DB2 server in the following folder: ..Program Files\IBM\DB2\SQLIB\java\).
2. Paste these jar files in the 'drivers' folder of your Cognos install.
3. Restart Cognos Services.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.7;11.0.6;11.0.5;11.0.4;11.0.3;11.0.2;11.0.1;11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22009618