IBM Support

"Unable to get the FullName property of the AddIn class" when attempting to log into Controller link from within Controller

Troubleshooting


Problem

User launches the 'main' Controller client. User clicks the green 'X' button (to launch the Controller Link). An error appears.

Symptom


Error Launching menu item 'Controller Link'

Unable to get the FullName property of the AddIn class

Cause

Incompatibility between Controller Excel add-in and third-party (non-IBM) 'Think-cell' addin

Environment

Client device has third-party (non-IBM) 'Thinkcell' Excel add-in installed.

Resolving The Problem

Fix:

Uninstall (or disable from inside Excel) the third-party (non-IBM) Think-Cell Excel add-in.

Workaround:

Launch Excel directly (from the Start menu icon), not from via the Controller client.

  • Once inside Excel, click the 'Controller' menu item and choose 'Logon' from here instead.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22009181