Troubleshooting
Problem
I see that some sessions in my Guardium reports have DB User as '?' The same sessions have Oracle errors in Exception reports The Oracle errors are ORA-12505 or ORA-12514
Cause
The Oracle errors are:
ORA-12505: TNS:listener does not currently know of SID given in connect descriptor.
ORA-12514: TNS:listener does not currently know of service requested in connect descriptor.
Full details and steps to resolve can be found in the Oracle documentation - Database Error Messages (External Non IBM link)
Due to the nature of these Oracle errors, it results in a session being created but no database user being available and the login fails. Guardium reflects this in the report.
Diagnosing The Problem
Check in a Guardium report in Exceptions tracking domain. For example the predefined report "Exceptions by Type". Exception Type -> Exception Type Description attribute contains the Oracle error codes.
Or by making your own query in the Exceptions Tracking Domain with Exception as the main entity, for example:
This basic query will show the number of ORA-125% exceptions. It could then be customized to include other details like client or server ip, session id and conditions as required.
If the sessions with ? DB User are appearing in this exception report, this explains the ? users.
Resolving The Problem
It is expected behavior for sessions with these Oracle errors to have ? DB User. Guardium is accurately reporting an error at the database side that results in no database user being available for that session.
To address these errors, investigation should be done by the Oracle database team in your organization.
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Document Information
Modified date:
16 June 2018
UID
swg22008887