Troubleshooting
Problem
When the draft return order is being deleted through Web call center , the status of the status of the Sales Order still remains Return created
Cause
This is due to a missing listener from the Sales Order pipeline
Resolving The Problem
In the SalesOrder pipeline, after the Create Return transaction add a listener : Remove From Listener.This Listener should have the pick up status as Return created and drop status as Shipped.
Once this listener is added to the pipeline , when the draft return is deleted, the status of the corresponding Sales Order will move back to Shipped
[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.5;9.4;9.3;9.2.1;9.2;9.1;9.0","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg22008413