IBM Support

Intermittent "IBM Cognos Controller has fired an exception" when saving layout

Troubleshooting


Problem

User launches Excel, and clicks "Controller - Logon". User chooses database, and logs on. Inside the 'Controller' add-in menu, user clicks the "Update Layout" then “Save Layout”. - This works OK (no error). Then user clicks “Update Layout” again, and then clicks “Save Layout”. - This time, an error appears.

Symptom

(1) User clicks "Update Layout"...

...then “Save Layout”


This works OK (no error).

(2) Then user clicks “Update Layout” again...


...then “Save Layout”


This time, an error appears:

IBM Cognos Controller


'IBM Cognos Controller' has fired an exception. Click the 'Details' button to see the detailed information about the error.
Detailed technical information follows:
---
(Inner Exception)
Date and Time: 9/6/2017 5:07:57 PM
Machine Name: <pcname>
IP Address: <ip>
Current User: <domain\user>

Application Domain: C:\Program Files\IBM\IBM Cognos Controller Local Client\
Assembly Codebase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
Assembly Full Name: mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
Assembly Version: 4.0.0.0

Exception Source: mscorlib
Exception Type: System.AccessViolationException
Exception Message: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
Exception Target Site: InvokeDispMethod

Cause

Client device has unsupported type of Microsoft Office installed.

  • Specifically, its MS Office was installed via 'click to run'.

More Information
Modern Microsoft Office versions can be installed in two different ways:
(1) Traditional method
  • This is sometimes called the 'MSI' or 'Windows Installer' method
    • It is also sometimes known as the 'Volume License' method
  • The application is installed (and runs) natively/directly on the users client device
  • This is supported for use with Controller.

(2) Click-to-run
  • The user "streams" the portion of Office that they need (downloading extra portions as and when they need it).
  • The software is running in an isolated 'Sandbox' environment ('virtual bubble') on the computer.
  • This is currently unsupported for use with Controller.

For more information on the differences, see separate IBM Technote #1984103.

Environment

Client device has Microsoft Office 'click-to-run' installed.

Resolving The Problem

Uninstall Microsoft Office 'click to run' and re-install MS Office using the standard (MSI) type installation.

More Information
For more information on the differences, see separate IBM Technote #1984103.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22008190