IBM Support

Cognos Mobile shows the Cognos Analytics web interface inside the sign-in dialog

Question & Answer


Question

When I try to connect the Cognos Mobile native app (iOS and Android) to a Cognos Analytics server, the web interface appears inside the sign-in window as opposed to providing me the normal native experience as in previous versions.

Cause

After entering the URL to my Cognos server, I get the following screen

Answer

The URL used to define the connection to the Cognos Analytics server needs to be structured as follows:

http(s)://[myserver:port]/bi/v1/disp/

To see all the changes when the app connects to a Cognos Analytics server, see the following article:


http://www-01.ibm.com/support/docview.wss?uid=swg21973325

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Mobile v11x","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.7;11.0.6;11.0.5;11.0.4;11.0.3;11.0.2;11.0.1;11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22008001