IBM Support

Node Capacity Consideration based on DeliveryMethod is not working properly

Question & Answer


Question

Why is Node capacity considered for orders despite not configuring capacity for SHIP delivery method in IBM Sterling Order Management.?

Cause

Node Capacity Consideration based on DeliveryMethod is not working properly.

Answer

As per product design, for a particular node

  • If no resource pool is defined, it is assumed that capacity tracking is not required.
  • If a resource pool when defined (with no delivery method), all delivery method will use the same resource pool.

When resource pool is defined for particular delivery method(say PICKUP), its unexpected that other delivery method does not have any capacity limitation. Configured Capacity is used for that particular delivery method(i.e. PICKUP in this example) and for other delivery method, the available capacity will be assumed to be zero. Hence those orders will not be scheduled against this node.

If Node Capacity is being used for a particular node, it is expected that it should be configured for all delivery methods.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.2;9.2.1;9.3;9.4;9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22007875