IBM Support

createOrder API fails for custom document type in Sterling Order Management

Troubleshooting


Problem

Attempts to create order leads to the error Invalid Transaction in IBM Sterling Order Management.

Symptom

The complete error message is as follows:
<Errors>
<Error ErrorCode="YCP0063" ErrorDescription="Invalid Transaction"
ErrorRelatedMoreInfo="" ErrorUniqueExceptionId="
10.12.232.3414871024664660000000000066">
<Attribute Name="ErrorCode" Value="YCP0063"/>
<Attribute Name="ErrorDescription" Value="Invalid Transaction"/>
<Attribute Name="BaseTransactionKey" Value="UPDATE_ORDER_INV_ASYNC"/>
<Attribute Name="ProcessTypeKey" Value="201408141555251175949"/>
<Attribute Name="ErrorUniqueExceptionId" Value="
10.12.232.3414871024664660000000000066"/>
</Error>
</Errors>

Cause

The BaseTransactionKey UPDATE_ORDER_INV_ASYNC is not associated with the custom document type.

Diagnosing The Problem

In this scenario, the migration happened from 9.4 to 9.5 version.

Resolving The Problem

Steps to resolve:

  1. Add the custom document entry in customdoctype.properties file
    For example: 00035.ex=0003

  2. Remove or comment line comprising of this --> from customdoctype.properties file. ( This is present at line 7 in your customdoctype.properties file)

  3. Changed directory to <9.5_INSTALL_DIR>\Migration\9.4 and run the below command:
    --------------------------
    <9.5_INSTALL_DIR>\Migration\apache-ant-1.7.1\bin\ant
    -Druntime=<9.5_INSTALL_DIR> -Druntime.old=<9.4_INSTALL_DIR> -f
    buildmigration.xml -logfile migrate-custom-doc-types.log
    -Dtarget=migrate-custom-doc-types migrate

    --------------------------

  4. Run the createOrder xml
    Sample input xml:
    --------------------------
    <Order DocumentType="00035.ex" EnterpriseCode="DEFAULT" OrderNo="123">
    <OrderLines>
        <OrderLine DeliveryMethod="DEL" OrderedQty="1" ShipNode="Node1" >
           <Item ItemID="Item1" UnitOfMeasure="EACH" />
       </OrderLine>
         </OrderLines>
     <PersonInfoBillTo Country="US" />
     <PersonInfoShipTo Country="US" ZipCode="40876"/>
       </Order>

    --------------------------
    This does not lead to any error:

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
11 February 2020

UID

swg22007773