Question & Answer
Question
How does the Reset flag affect the behavior of managePricingRule API in IBM Sterling Order Management?
Cause
Inconsistent behavior of Reset flag while creating/modifying pricing rules
Answer
The behavior of Reset flag is consistent and it actually works in below fashion –
If Reset is passed as Y in <PricingRuleTargetItemList> in managePricingRule API to modify the pricing rule, the existing item ids (quantity tiers) will be removed and replaced with the new ones, But, only as long as the item Id in the input does not already exist in the table YPM_PRICING_RULE_ITEM.
If any such item Id (passed within input) already exists in the table, only its timestamp gets updated.
Product Synonym
Sterling Order Management;Sterling OMS;SSFS;Sterling Selling and Fulfillment Suite
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg22001095