IBM Support

IBM Security Guardium - Errors in GUI "Operation could not complete due to a database error."

Troubleshooting


Problem

You have recently upgraded from v9 using the "restore from previous database" option and are getting errors in the GUI when accessing various reports: "Operation could not complete due to a database error."

Symptom

After clicking OK on the pop up box, you see:
"You do not have privileges to see this report."

Cause

The restore has overwritten changes from patch 10.1.2 p205.

Environment

v10.1.2 p205.

Diagnosing The Problem

The debug-log shows the error:
==============Thu Mar 16 13:01:24 MDT 2017===================
Thread: http-bio-8443-exec-9 -
com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown
column 'QUERY_HEADER.NEW_SHOULD_RUN_IN_TWO_STAGES' in 'field list'
at sun.reflect.GeneratedConstructorAccessor85.newInstance(Unknown
Source).

Resolving The Problem

Re-apply p205

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.1.2","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22000830