IBM Support

QE-DEF-0368 Unable to Decrypt User Name and Password

Troubleshooting


Problem

When attempting to create a database connection in Framework Manager the following error message is displayed. 

Symptom

Error: QE-DEF-0368 Unable to decrypt user name and password from the Content Store. Use Cognos Configuration to configure your reporting environment.

Cause

The signing and encryption certificates stored on the Framework Manager installation are not in sync with the content store, preventing Framework Manager from successfully accessing the encrypted data (specifically, the data source signon username and password).
This had worked previously but a recent change in the environment, in particular a change of application servers, has occurred. This usually occurs when Framework Manager is installed on a separate computer from the Cognos Business Intelligence server; however, it can happen if Framework Manager is installed in a separate folder on the same server.

Resolving The Problem

Note: Ensure that a backup is kept of all modified files and directories.

Step 1:
1. Start up Cognos Configuration where Framework Manager is installed and re-save the configuration.
2. Start up Framework Manager and attempt to create your database connection.
3. If that doesn't work then continue with Step 2.

Step 2:
1. Exit Framework Manager.
2. Regenerate the encryption keys as per the below technote.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22000634