IBM Support

How can we confirm a shipment with 0 quantity and retain the shipment line?

Troubleshooting


Problem

When an order is created with a regular item and a bundle item, consider the following scenario - 1. Schedule and Release the order 2. Create one shipment for both the lines During shipment confirmation, pass quantity as 0 for the bundle parent. Expectation - Shipment line should be cancelled but retained on the shipment and order for invoicing purpose Actual - Shipment remains in "Included in Shipment" with qty 0

Cause

For this use case, changeShipment should also be used to make the necessary changes.

Resolving The Problem

The solution is to call changeShipment to cancel the quantity prior to calling confirmShipment.
Call changeShipment using -
<Shipment CancelRemovedQuantity="Y"
CancelShipmentOnZeroTotalQuantity="Y"
SellerOrganizationCode="Matrix"
ShipNode="Matrix_WH1"
ShipmentKey="2016100616080921003" ShipmentNo="100000001">
<ShipmentLines>
<ShipmentLine Action="Cancel" ShipmentLineNo="1"/>
</ShipmentLines>
<Containers/>
</Shipment>
Here CancelRemovedQuantity and CancelShipmentOnZeroTotalQuantity helps ensure that the shipment is cancelled when all shipment lines have zero quantity. Using this , the shipment line moves to Cancelled status while being retained on the order for invoicing purpose

Call confirmShipment after this API call

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"9.2.1;9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22000365