IBM Support

Guardium Audit Process error 'Could not get the Datasource Factory for the connection' after installing patch

Troubleshooting


Problem

After I installed a patch on my central manager (CM) and managed units, some audit tasks run with managed units as a remote source are failing. In the results output for the audit task, the error is: Error: Unexpected problem when connecting to: 'managed_unit_hostname_gdmaudit'.: Could not get the Datasource Factory for the connection: 'managed_unit_hostname_gdmaudit'.

Cause

In the one reported case of this error, sniffer patch v9 p4073 was installed on the environment before problem started. The error seems to have been caused by conflict between patch install and managed unit refresh process.

Resolving The Problem

Two steps may resolve this problem:

  • Restart GUI on the CM
  • Re add the managed units in the remote source parameter in the audit task definition for the failing audit task. Apply the changes. The definition can be found in Tools -> Audit Process Builder

If one of the above does not resolve please contact Guardium support. Attach the output of support must_gather app_issues. When prompted, run the debugger for a number of minutes and reproduce the problem in that time by running the audit process 'once now'.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Appliances","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"9.0;9.1;9.5","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21999800