IBM Support

How to manage user licenses in Cognos Analytics

Question & Answer


Question

Issue: A user is still showing in the license report even though they have been deleted in the external authentication source.

Cause

The license is tied to the user profile. Even after deletion in the external authentication source, the user's profile still remains in the Content Store.

Answer

In order to fix this, execute a consistency check against external reference then restart Cognos Analytics. Once you refresh the licenses, the number of used licenses will reduce to reflect the user deletion.


Steps on how to execute a consistency check: 

  1. Open Cognos Analytics Administration Console
  2. Select the Configuration Tab
  3. On the left hand side menu, select Content Administration
  4. On the top right within the main window the 5th icon inwards is New Content Maintenance, select then click on Consistency Check.
  5. Give it a name, select Next
  6. Select References to external namespaces: All namespaces
  7. Action: Save and run once, Select Finish
  8. Select Now, then Mode is either: Find only or Find and Fix. Initially worth running Find only
  9. Tick the box "View the details of this content maintenance task after closing this dialog"
  10. Hit OK
  11. Hit refresh on the next page until the results populate.

 

Repeat steps 8-11 again to do the Find and Fix.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
28 November 2018

UID

swg21999694