IBM Support

Unable to monitor availability for CARRY delivery method in Sterling Order Management System

Troubleshooting


Problem

Attempts to add CARRY delivery method to manageInventoryMonitorRule API does not monitor the Inventory in IBM Sterling Order Management 9.5

Symptom

The manageInventoryMonitorRule API provides a DeliveryMethod attribute that can be used to add Delivery Methods to monitor for an Inventory Monitor Rule.

Steps to reproduce:

  1. Create a distribution group (e.g. DG1) containing a node (e.g. Nod1)


  2. In Global Inventory Visibility > Inventory Rules > Monitor Rules tab:
    a) For Distribution Group To Use For Node Level Monitoring, subscribe DG1.
    b) Create a Monitor Rule (e.g. MR1) & select it as Default Node Level Inventory Monitor Rule.


  3. Create an item (e.g. Itm1). Shipping & Pickup is allowed for it.
    Select Node Level ATP Monitor Rule as MR1.


  4. From Sterling Business Center (SBC), create a resource pool (e.g. RP1) with both the Delivery Methods i.e. Ship, Pickup checked.


  5. Adjust ONHAND inventory (e.g. 100) of Itm1 at Nod1.


  6. From API tester, call manageInventoryMonitorRule API with below input: <InventoryMonitorRules InventoryMonitorRule="MR1" OrganizationCode="DEFAULT">
    <DeliveryMethodListToMonitor>
    <DeliveryMethodToMonitor DeliveryMethod="SHP"/>
    <DeliveryMethodToMonitor DeliveryMethod="PICK"/>
    <DeliveryMethodToMonitor DeliveryMethod="
    CARRY"/>
    </DeliveryMethodListToMonitor>
      </InventoryMonitorRules>



  7. Run the Real Time Availability Monitor (RTAM) agent in full sync mode.


  8. Check the availability for Delivery Methods in the database.
    e.g. select ship_node, delivery_method, count(*)
    from yfs_inventory_alerts
    where ship_node='Nod1'
    group by ship_node, delivery_method;

Availability can be seen for PICK and SHP delivery methods but not for CARRY delivery method.

Cause

This is Working as Designed.

Diagnosing The Problem

The availability can be published for PICK and SHP delivery methods, but it can't be published for CARRY delivery method.

Resolving The Problem

This is an expected behavior in Sterling OMS 9.5 for CARRY delivery method.

Availability can be monitored for PICK and SHIP delivery methods, but it can't be done for the CARRY delivery method.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21997996