Troubleshooting
Problem
Unable to start Cognos from Cognos Configuration.
Symptom
In cbs_start.log and/or cbs_run.log:
CAM-CRP-0026 An error was returned from the underlying socket implementation
In pogo_yyyy-mm-dd.log:
Unable to find an active CM. Will try sending an elect command
In cbs_isrunning.log:
CBSBootstrapService Process is not running
In cogserver.log:
DPR-CMI-4006 Unable to determine the active Content Manager. Will retry periodically.
Cause
URIs in Cognos Configuration that are still set to the default "localhost"
Environment
HP-UX
Resolving The Problem
Replace all instances of "localhost" with either a Fully Qualified Domain Name (FQDN) or an IP address (an FQDN is generally preferable).
This should be done even if referring to the local machine.
Also note this error could occur in a multiserver environment if the Content Manager URIs specified in Cognos Configuration on each server do not point to the correct server where the Content Manager is installed. It is also important to make sure that the primary Content Manager server is running before any other servers are brought online.
Steps:
1. Launch Cognos Configuration (cogconfig.sh)
2. In the Explorer window, check the settings in configuration areas such as "Environment" or "Logging".
3. Within the properties window at right, ensure that any field requiring a hostname has either a FQDN or an IP address as the hostname.
*** Unless required by your particular configuration, only change the hostname within a URI. Do not change other information within URIs you are modifying.
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Document Information
Modified date:
15 June 2018
UID
swg21997933