IBM Support

CodeModules folder not found error with IBM Enterprise Records (IER)

Troubleshooting


Problem

During an IER installation when running the Configure Workflows task an error is thrown by the IER Configuration Tool stating that the CodeModules folder required cannot be found in IBM FileNet P8 Content Engine Object Store (OS).

Symptom


The following error appears:

The requested item was not found. Folder /CodeModules not found.

Cause

This issue occurs after using the Composite Platform Installation Tool (CPIT) which does not create the CodeModules folder required by IER during Content Platform Engine (CPE) installations.

Manual object store creation includes this folder by default so this issue does not occur. It should also be noted that other applications which depend on this folder (eg. IBM Case Manager) have a verification process to ensure this folder exists. IER currently does not have this feature.

Environment

IER 5.2.0

CPE 5.2.1

Resolving The Problem

The issue is resolved by recreating the FPOS object store and rerunning the FPOS configuration tasks.

[{"Product":{"code":"SSNVVQ","label":"IBM Enterprise Records"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.2.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21995936