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Constant "-W- System is in boot run level ... will skip any checks" in Guardium GIM.log and central_logger.log when attempt STAP install from GIM

Troubleshooting


Problem

Constant "-W- System is in boot run level ... will skip any checks" in Guardium GIM.log and central_logger.log when attempt STAP install from GIM

Symptom

The Guardium GIM client is installed with success. A subsequent attempt to install the STAP module from the Guardium GUI via GIM results in the STAP appearing to be stuck in Pending Install. Constant messages in the GIM.log and central_logger.log are seen every minute - like this example :-

[Tue Nov 15 21:44:36 2016] -W- System is in boot run level ... will skip any checks
[Tue Nov 15 21:45:36 2016] -W- System is in boot run level ... will skip any checks

Cause

Guardium uses the " who -r " Operating System command of the DB Server to check the run level - and hence checks if the system is in a stable state for the STAP to be installed.

For example on an AIX system this is a legitimate return from who -r

    $ who -r
       .        run-level 2 01 Nov 06:26       2    0    S

There are the following different causes


    1. In some systems a "blank" is returned from the " who -r " command - this is a problem with the Operating system - For example on AIX - Possibly the /etc/utmp file is corrupted or has bad permissions.

    2. If a Server returns output from commands in a local language - Guardium is not interpreting this correctly. - For example a French system returns a correct run level as follows which Guardium fails to interpret. this example taken from a French Linux system

      root@xxxxx~]# who -r
               niveau d'exécution 5 2016-11-29 15:50

Diagnosing The Problem

check the central_logger.log and GIM.log files as above - They are found in the <guardium installation directory>/modules area

Resolving The Problem

1. If a blank is returned as in case 1. above


    Your system Administrator will need to investigate further - Essentially the Guardium must have the " who -r " command return a correct value. In previous cases where AIX returned a blank a reboot of the system has helped reset the corrupted /etc/utmp file such that the " who -r " command returns a valid value.

2. Where a localised DB Server is used (eg Frennch / German etc) Guardium has produced a fix to be available in v10.5 and higher.


    For customers who need a temporary fix before any patch is available please raise a PMR with IBM Guardium Technical Support who can then advise accordingly.

    For IBM Guardium Technical Support engineers - please check the Internal Notes of this document via the IBM Internal tooling in order to help customers with this problem


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Document Information

Modified date:
16 June 2018

UID

swg21995313