IBM Support

Incorrect delivery and shipment dates are stamped on order

Troubleshooting


Problem

Attempts to schedule an order stamps incorrect Expected Time of Delivery (ETD) and Expected Time of Shipment (ETS) in IBM Sterling Order Management.

Symptom

Steps to reproduce:

  1. From Application Manager, Go to : Logistics Management -> Cross Application -> Carrier Services.


  2. Create two Carrier Services : Carrier 1 and Carrier 2 with same Transit Days & Delivery Schedule.


  3. Define Node's calendar working hours & Carrier Pickup Times for Carrier 1 & Carrier 2.
    - Node's calendar working hours [07:00 - 20.00
    - Node's Carrier Pickup Schedules:
    Carrier 1 : [09:00]
    Carrier 2 : [06:00]


  4. Create first order from Sterling Order Management System (OMS) with Carrier 1.


  5. Create second order from Sterling OMS with Carrier 2.


  6. Schedule both the orders. Compare the ETD and ETS dates for both the orders.

Result: Incorrect ETD and ETS dates are stamped for order having Carrier 2.

Cause

This is an invalid business use case.

Resolving The Problem

When calendar is enabled then Carrier Pick Up times, Requested Ship and Delivery date, Node Transfer, cut-off times, calendar shift exceptions - have to be within the working hours to be considered.
else calculations will be as per Node working hours only.

NOTE: CreateOrder API is not expected to throw any exception in such cases.

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
10 May 2022

UID

swg21986935