Question & Answer
Question
How do you create order for a newly created organization in IBM Sterling Order Management?
Cause
For a newly created organization, when you try to create an order from Application Console, the order lines and other features are unusable (i.e. disabled or greyed out).
Answer
Steps to reproduce:
- Create a new organization (e.g. ENT1).
a. Parent Organization: DEFAULT
b. Primary Enterprise: ENT1
c. Role: Enterprise, Seller
d. Inventory, Catalog, Capacity organization: ENT1.
- Create an Order in Application Console.
- Select "ENT1" as Enterprise and Seller. Specify a country code (e.g. US).
- Click on Create Order button
As a result, the order lines and other features are unusable (greyed out).
When an order is created with Enterprise: DEFAULT & Seller: ENT1, it works.
To resolve, define the modification rules for the new organization using below steps:
- Launch Distributed Order Management from Application Manager.
- Click on the hammer icon for 'Load Rules for Organization' and select the organization (e.g. ENT1), and click Ok.
- Go to option : Document Specific - Sales Order - Fulfillment - Order Modification.
- Double click on Order Modification Groups and create a new Status Modification Group (e.g. Group1) and Save.
- Click on Copy Hub Rules icon at the right top.
- On Confirmation dialog, Click Ok.
- Create a new order from Application Console with Enterprise & Seller as ENT1.
Order will get created properly.
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Document Information
Modified date:
10 May 2022
UID
swg21986919