IBM Support

Unable to view reports on the Guardium GUI

Troubleshooting


Problem

When I try to view reports as Admin user in the Guardium GUI, they are all blank and show no data.

Symptom

Blank reports in GUI.

you may see a message on the report for example:-


No data found for current runtime parameters

Cause

Data level security filtering is enabled to filter report data according to user role. This may have been enabled by mistake or needs reviewing

Environment

Guardium Version 10

Diagnosing The Problem

The server is up and running, data collection also takes place, but there are no reports that can be seen at all.

If Data Level Security is enabled you may see the following checkbox at the bottom of the report page to the left


Include indirect records - This indicates that the Data Level Security DLS is currently enabled and may be filtering the report results

Resolving The Problem

Disable Data Level Security Filtering as a test to see if the feature is filtering all reports for the user:

On the Guardium V10 GUI, navigate to Setup > Tools and Views > Global Profile. Scroll down and click on "Disable".

If reports are able to be viewed after this change, it may be an indication to review the current roles, privileges or user hierarchy if this feature is intended to be used.

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Document Information

Modified date:
16 June 2018

UID

swg21986542