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Guardium v8.2 p6019 install fails

Troubleshooting


Problem

I can not install p6019 on my Guardium v8.2 appliance. When I run "show system patch installed" the status is failed.

Cause

An rpm in existing on the system is blocking p6019 install. This does not affect all v8.2 appliances, but those with a certain combination of patches installed previously.

Diagnosing The Problem

To confirm you have this problem follow these steps:

1. In the appliance fileserver find the p6019 install file. This will be located in diag/depot e.g.


    patch-8.2p6019_20160512142213.log

2. Check in this file for the following lines:
    error: Failed dependencies:
        openssl = 0.9.8e-27.el5_10.4 is needed by (installed)
    openssl-devel-0.9.8e-27.el5_10.4.i386

3. If those lines exist in the log then the solution below applies. If the log does not have these lines there is a different problem. Contact Guardium support and attach support must_gather patch_install_issues for further investigation.

Resolving The Problem

There is an ad hoc patch p1193 that should be installed to resolve this problem. The patch is only available by contacting Guardium support. When opening a PMR attach:

  • Output of support must_gather patch_install_issues
  • Reference to this technote

Related Information

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Appliances","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"8.2","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21984771